This is documentation for Mathematica 5, which was
based on an earlier version of the Wolfram Language.
View current documentation (Version 11.2)

Documentation / Mathematica / Add-ons & Links / J/Link / Requirements /

Version Requirements

J/Link requires Mathematica 4.0 or later and is compatible with all platforms on which Mathematica is available. This does not include Macintosh System 8 or 9, as the current version of Mathematica is no longer available for that platform.

J/Link requires a Java runtime that is version 1.1 or later. It is strongly recommended that you get the latest Java runtime available for your platform. It is best to have a Java version of 1.3 or later. For some of the example programs, you must have Java 1.2 or later. Mathematica 4.2 and later includes a Java runtime, so you do not need to obtain and install one separately.